Logo of SermonSpeaker Extension Claim

Login Form

× Support for SermonSpeaker 4.x is canceled as it is for Joomla 2.5. I will gladly assist you with minor issues but I will not fix any bugs anymore in this releases.
The fix is to upgrade to SermonSpeaker 5.x and Joomla 3.x, which is better anyway.

Frontend Upload limited to 2M

More
5 years 2 months ago #3840 by Thomas Hunziker
Also just for reference, this is the code used in /components/com_sermonspeaker/views/frontendupload/view.html.php which checks the settings:
// Check some PHP settings for upload limit so I can show it as an info
$post_max_size			= ini_get('post_max_size');
$upload_max_filesize	= ini_get('upload_max_filesize');
$this->upload_limit		= ($this->return_bytes($post_max_size) < $this->return_bytes($upload_max_filesize)) ? $post_max_size : $upload_max_filesize;

You can read about ini_get here: php.net/manual/function.ini-get.php . It returns the currently active value for a given option. Unlike get_cfg_var() which would return the value set in php.ini, regardless of what is done during runtime.

Also there is no filesize limit set by SermonSpeaker itself, neither in the Flash upload script nor in the actual upload processing. If the upload fails, it's due to server settings. Especially if there is an error 500 involved.
Usually you can see what caused the issue in the server (apache) error log.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #3841 by warmbrod
SermonSpeaker back-end shows a 50M limit and I just uploaded a 5M file. It is the front-end which shows/limits to a 2M and would not allow a 2.9M file. Error = Warning: Failed to move file!
The file cannot be uploaded

For some reason there is a difference between what the front-end allows and the back-end.

Thank you for looking into this.

Bruce

Oh, according to the reference I looked at ini_get does read the php.ini file as I suspected. I would guess your back-end is reading the system parameters.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #3842 by Thomas Hunziker
The backend uses the exact same code, and it reads the runtime configuration.
Also those two values can't be set by using ini_set(). So they can't be changed during runtime. This means it's set per directory using a php.ini, .htaccess, httpd.conf or .user.ini.

You can test the settings for your Joomla root directory by writing the following code into a test.php file and put that file into the Joomla root directory.
<?php phpinfo(); ?>

If you then access this file with your browser ( www.yourdomain.com/test.php ), it will get you the same information you also see in your Joomla backend, but this time for the frontend directory. You also see the relevant configuration files there. Notice that the value for 'upload_max_filesize' or 'post_max_size' is set to 2M.

As said already multiple times: If the upload fails based on the filesize, it's not related to SermonSpeaker. It can't be related to SermonSpeaker, because there are no such checks done there. It is related to your server settings. Please check the server error log if you don't believe me.
Also as said multiple times: The information shown about your upload limits are settings of your server, it's not a bug in SermonSpeaker reading wrong values, especially since the upload indeed fails as predicted. It can't be because it's the PHP way to read those values.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.
Last edit: 5 years 2 months ago by Thomas Hunziker.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #3843 by warmbrod
Thomas,
I would like to thank you for your help and I think we are almost there. When I run the phpinfo from the administrator directory I do see the 50M limit for Upload and Post which I assume is what your backend is using since it uploads files as desired. That is apparently why the Joomla admin console shows those numbers also.

So what I need to do is add another PHP.ini to the directory for the frontend since I cannot change the root php.ini file. Would that be placed in the components directory or the components/com_sermonspeaker directory?

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #3844 by Thomas Hunziker
The relevant directory is where the initial index.php file is located. So for frontend it has to go into your Joomla root directory because the index.php there is the entry file for the frontend.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

Time to create page: 0.126 seconds
Powered by Kunena Forum