Logo of SermonSpeaker Extension Claim

Login Form

RSS feed redirects to homepage now

More
2 weeks 4 days ago #7342 by Jimmy Su
Hi Thomas,

We have an RSS feed that we have been using without issue for several years now. A few weeks ago, the RSS feed has stopped working now redirects to the homepage. I thought it was intermittent, but I cannot seem to find the issue. Can you help me out here? The link is:

www.newlifelajolla.org/index.php?option=...monspeaker&view=feed

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #7343 by Thomas Hunziker
There is an error shown on the page:

Error
You are not authorised to view this resource.

That is most likely some sort of system plugin which tries to be smart and thus breaks the site.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #7344 by Jimmy Su
Hmm... can you give me a recommendation on how I can go about trying to troubleshoot this?

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #7345 by Thomas Hunziker
I'd try with disabling 3rd party system plugins and test if it solves something.
Starting with those in relation to security functions.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

More
2 weeks 21 hours ago #7346 by Jimmy Su
It didn't seem to solve the problem. Actually I don't have that many 3rd party plugins on the site are SermonSpeaker's and Akeeba Backup.

I've noticed that when I'm logged in as Administrator (Super User) on the frontpage, I can access the feed just fine. Looking back, it appears this issue happened towards the end of September. Maybe after a Joomla update? Any other suggestions you might have? All the other SermonSpeaker "views" (e.g. view=speakers, view=series, etc...) in the /models folder work fine. The feed.php script is the only one that has this issue.

Please Log in or Create an account to join the conversation.

More
2 weeks 8 hours ago #7347 by Thomas Hunziker
Do you have any category that isn't public?
I don't think a Joomla update is the source. Since it works on this page and on my church site.
If you want to give me access to your backend, I can have a look if I see something that could cause this. You can send me the user credentials to This email address is being protected from spambots. You need JavaScript enabled to view it. or use the contact form.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

Time to create page: 0.103 seconds
Powered by Kunena Forum