Logo of SermonSpeaker Extension Claim

Login Form

Can hear Video But Can't See it

More
1 year 4 weeks ago #6866 by Scott
Hello!!

I just recently upgraded all software on my site hopping this problem would get fixed in the process but, did not.

I've always had the problem of not being able to see the video playing. I can hear it but, not see it. I'm currently using JWPlayer 7 plugin but, I couldn't get this to work with the Sermonspeaker pre-installed ones.

Any help you can provide would be greatly appreciated.

Here is on sermon detail page link that shows the problem.
www.threeheartschurch.org/index.php/serm...s-part-two-salvation

Thanks and Best regards,
Scott

My setup:
SermonSpeaker 5.7.1
Joomla 3.8.1
PHP 7.1

Please Log in or Create an account to join the conversation.

More
1 year 4 weeks ago #6867 by Thomas Hunziker
The layout (icons) you use for the detailpage doesn't work well with a video playing directly in it. Also the JW Player looks quite ugly. It looks best with the Pixelout player.
For the video, there is a second "player" bar which opens a popup. That's the intention here and that actually works.

If you want to play the video within the detailpage itself, try with another layout like the "content" one.
Of course, if you want to show the videoplayer by default, set the priority for the player to "video", otherwise it may take the mp3 one if both an audio and videofile are present.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

More
1 year 4 weeks ago #6868 by Scott
Thank you Thomas for your quick reply!
I changed it to "content" style and set the priority to "video" but, it still don't work. I tried the pixelout player too but, it won't play the video file, only plays the audio file. I removed the audio file from the sermon leaving only the video file and the error message was "no matching player found".

Now the current setup is with the JWPlayer with "content" style selected.

Please Log in or Create an account to join the conversation.

More
1 year 4 weeks ago #6869 by Thomas Hunziker

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

More
1 year 4 weeks ago #6870 by Scott
Oh, how interesting... On my WIN7 pc I use Chrome as my default browser. I get no video in it or Explorer 11. And also will not work on my Android phone using Chrome. But on my wife's WIN10 Explorer and on my cell phone Android internet browser it works.

I guess not all browsers are created equal. ;-)

Please Log in or Create an account to join the conversation.

More
1 year 4 weeks ago #6871 by Thomas Hunziker
It's true that not every browser is created equal :)But then IE11, Chrome and Edge (on WIn10) are major browsers and I would expect them to work.

It may also be some caching issue (browser cache sites). Other than that you would have to check the browser console (usually F12) for error messages. There may be some bad JavaScript code somewhere.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

Time to create page: 0.114 seconds
Powered by Kunena Forum