Logo of SermonSpeaker Extension Claim

Login Form

"search orphaned files" tool - false positive?

More
1 year 1 month ago #6834 by B.Pohl
Hi guys,

Thanks so much for the work you continue to do with sermonspeaker, it's been a wonderful tool for several churches whose websites I maintain!

Quick question: I am seeing a bunch of false positives when I use the search orphaned files tool. Path to audiofiles is set to messages/004 and each of the orphaned files that the tool finds consists of file paths along these lines: /messages\004/sermon_something.mp3 (marked with a backward slash).

Is there something I might have done to cause this?

thanks!

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #6835 by Thomas Hunziker
Sounds like some Windows server is involved?

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #6836 by B.Pohl
You're on the money... I'm using xampp (win10) for server testing before uploading it to my linux server...

Does that mean these issues will resolve themselves once it's on the linux server?
thanks!

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #6837 by Thomas Hunziker
Yep, on a Linux server, you will not have this issue. Windows uses \ as a directory separator while linux (and mac) use /. Since SermonSpeaker does a simple string compare, you've got an issue here on your Windows machine.
I'm sure I can make it work for Windows as well. But for you, it shouldn't be an issue once its on the productive server.

Feel free to rate SermonSpeaker on JED .
Useful documentation for beginners: First Steps & FAQ
How to say "Thank You!": Contribute or support using the Donate button at the bottom of each page.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #6838 by B.Pohl
Great! I'm not worried about the behaviour... Just wanted to catch oddities before putting it on the production server.

thanks for the support!
The following user(s) said Thank You: Thomas Hunziker

Please Log in or Create an account to join the conversation.

Time to create page: 0.100 seconds
Powered by Kunena Forum