Logo of SermonSpeaker Extension Claim

Login Form

SermonSpeaker 5.9.5 is released.
Minimum Joomla! Version: 3.8.0

Fixes

  • The "Play the sermon" link in the dropdown menu in blog layouts now works correctly