Logo of SermonSpeaker Extension Claim

Login Form

SermonSpeaker 5.9.4 is released.
Minimum Joomla! Version: 3.8.0

Feature

  • Feed can now be filtered by speakers and series

Fixes

  • Fixing a JS error when there is no player on the page.