Logo of SermonSpeaker Extension Claim

Login Form

SermonSpeaker 6.0.0 is released.
Minimum Joomla! Version: 4.0.0

SermonSpeaker and Joomla 4.0

SermonSpeaker 6.0.0 requires at least Joomla 4.0.0. It's the first release for the new major Joomla version and will be the main version for the future.

SermonSpeaker 5.x will go into maintenance mode similar to how Joomla 3.x will get no further feature anymore. SermonSpeaker 5.x will still be maintained for the time that Joomla 3.10 will be maintained, which is until August 2023.

Updating

First you will need to update Joomla itself to the 4.x version. Afterwards you will see the updates to the extensions in the extension manager.

Improvements

  • Obviously Joomla 4.0 support
  • Categories are now independant for sermons, series and speakers. The're no longer shared between the three sections. During the update, the categories are copied and sermons, series and speakers are assigned to the new category. You may need to check menuitems if the category selection still matches there.

If you find any bugs, please let me know so I can fix them.